В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ммаа2
ммаа2
14.03.2021 16:43 •  Информатика

ИВТ СОЧ Составить программу, которая в зависимости от порядкового номера месяца (1, 2, ..., 12) выводит на экран количество дней в этом месяце. Рассмотреть случай, что не високосный.

Показать ответ
Ответ:
oleg173173173
oleg173173173
09.03.2021 15:40

програмка:

#include "stdafx.h" #include <iostream> #include <cstdlib>   using namespace std;   int main(int argc, _TCHAR* argv[]) {     setlocale(LC_ALL, "RUS");     cout << "Введите месяц: ";     int m;     cin >> m;       if(m == 2)     {         char ch;         cout << "Год високосный? (y/n):";         cin >> ch;         if(ch == 'y')             cout << "В этом месяце 29 дней" << endl;         else if(ch == 'n')             cout << "В этом месяце 28 дней" << endl;     }       if((m % 2))         cout << "В этом месяце 31 день." << endl;     else     {         if(!(m % 2))         {             if(m != 2)                 cout << "В этом месяце 30 дней." << endl;         }     }         system("pause");     return 0; }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота