В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
егор23578584
егор23578584
19.01.2022 18:56 •  Информатика

/ивт 9 класс делфи / паскаль/ 50 напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. время работы программы должно быть пропорционально корню из n. входные данные программа получает на вход одно число n< 2^31. выходные данные программа должна вывести все простые натуральные делители числа n с учетом кратности в порядке неубывания. примеры входные данные 6 выходные данные 2 3

Показать ответ
Ответ:
lour1
lour1
04.10.2020 00:52
Var
 n,d,k:int64;
begin
 read(n);
 d := 2; k := 4;
 while k <= n do
  begin
  while n mod d = 0 do
    begin
    write(d,' ');
    n := n div d;
    end;
  k := k + 2*d + 1;
  d := d + 1;
  end;
 if n > 1 then write(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота