В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Versija02
Versija02
24.04.2021 22:22 •  Информатика

Исправь ошибки в программе.укажите их число
program a;
const x:50;
c:1000;
var SUM,pr,d : integer;
begin
sum:= x+c;
writeln( sum);
pr := X*c;
writeln (pr);
d:=x/c;
writeln (d);
end.​

Показать ответ
Ответ:
medovd
medovd
14.03.2020 16:14

x

2

+

y

2

=

16

...

...

...

...

...

...

.

.

(

1

)

x + y = 4 (2)

rearrange (2) to y = 4 - x (could do x = 4 - y )

substitute y = 4 - x into (1)

hence:  

x

2

+

(

4

x

)

2

=

16

x

2

+

16

8

x

+

x

2

=

16

and  

2

x

2

8

x

+

16

16

=

0

2

x

2

8

x

=

0

factor and solve : 2x(x - 4 ) = 0  

x

=

0

,

x

=

4

substitute these values into y = 4 - x , to find corresponding values of y.

x = 0 : y = 4 - 0 = 4 → (0 , 4)

x = 4 : y = 4 - 4 = 0 → (4 , 0 )

These are the points of intersection with the line x +y = 4 and the circle  

x

2

+

y

2

=

16

Answer link

Объяснение:

0,0(0 оценок)
Ответ:
костелои
костелои
27.12.2021 20:09

Пример на продукте - бананы

program v1;

var m,n,sum,t:integer;

st1:string[10];

 begin

   sum:=0; t:=0;

   writeln('Здравствуйте');

   writeln('Банан красного цвета стоит 2500, банан синего цвета стоит 3000, банан черного цвета стоит 3700');

   writeln('Сколько купите бананов '); readln(n);

  writeln('Введите цвет бананов '); readln(st1);

   if (st1='Красного') or (st1='красного') or (st1='Красный') or (st1='красный') then sum:=3000*n;

   if (st1='Синего') or (st1='синего') or (st1='Синий') or (st1='синий') or (st1='Синей') or (st1='синей')  then sum:=2500*n;

   if (st1='Черного') or (st1='черного') or (st1='Чёрного') or (st1='чёрного') or (st1='Черный') or (st1='черный') or (st1='чёрный') or (st1='Чёрный')  then sum:=3700*n;

   writeln('Сумма покупки ', sum);

   writeln('Введите сумму'); readln(m);

   t:=m-sum;

   writeln('Возьмите сдачу ',t);

   writeln('Всего доброго, приходите еще');

 end.


Дорогие программисты по информатике! Напишите программу по этим алгоритмам умоляю
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота