В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nata27veronika
nata27veronika
17.04.2022 05:28 •  Информатика

Используя язык программирования QBasic, составьте программу, которая выведет на экран ваши фамилию, имя, отчество и номер группы так, чтобы каждое слово находилось в отдельном углу экрана. Используйте операторы PRINT и LOCATE (для набора теста используйте символы английского алфавита). текст программы предоставьте в качестве ответа

Показать ответ
Ответ:

Программа:

{Free Pascal Compiler version 3.0.4+dfsg-23 [2019/11/25] for x86_64}

{Copyright (c) 1993-2017 by Florian Klaempfl and others}

{Target OS: Linux for x86-64}

program test;

const

 start = -100;

 finish = 50;

 count = 100;

var

 X : array of integer; {массив}

 i : integer; {Счётчик цикла}

 S : integer; {Сумма положительных}

begin

Randomize;

SetLength(X, count+1);

{Генерация массива из 100 элементов от -50 до 50}

for i := 1 to count do

 X[i] := Round( Random * start) + finish;

{Вывод сгенерированного массива на экран}

for i := 1 to count do

 write(X[i]:4);

writeln; writeln;

{Подсчёт положительных элементов}

S := 0;

for i := 1 to count do

 if (x[i] > 0) then

  S := S + x[i];

 

writeln('Сумма положительных S = ', S);

end.


Найти сумму тех элементов массива, которые имеют положительные значения(для Паскаль)​
0,0(0 оценок)
Ответ:
AlinaLove200413
AlinaLove200413
07.04.2023 04:31

#include <iostream>

#include <vector>

#include <cstdint>

using namespace std;  template <class T>

istream& operator>>(istream &in, vector<T> &vec) {   for (auto &it : vec)     in >> it;   return in;

}  

template <class T>

ostream& operator<<(ostream &out, vector<T> &vec) {   for (auto &it : vec)     out << it << ' ';   return out;

}  

template <class T, class U>

istream& operator>>(istream &in, pair<T, U> &pair) {   in >> pair.first >> pair.second;   return in;

}  

template <class T, class U>

ostream& operator<<(ostream &out, pair<T, U> &pair) {   out << pair.first << ' ' << pair.second;   return out;

}

signed main(void) {     int32_t n; cin >> n;     vector<vector<int64_t>> a(n, vector<int64_t>(n,-1));     int64_t x = 0, y = n/2;     a[x][y] = 1;     for(int32_t i = 2; i <= n*n; ++i) {         int _x = x, _y = y;         if(!x) {             x =  n-1;         }         else {             --x;         }         if(y == n-1) {             y = 0;         }         else {             ++y;         }         if(a[x][y] != -1) {             x= _x, y = _y;             while(a[x][y] != -1) {                 if(x == n-1) {                     x = 0;                 }                 else {                     ++x;                 }             }         }         a[x][y] = i;     }     for(int32_t i = 0; i < n; ++i) {         cout << a[i] << '\n';     }     return 0;  }

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота