Используя оператор for, написать программу в Паскале, которая вычисляет среднее арифметическое положительных чисел в промежутке от М до Р, где М>Р и М и Р положительные числа.
var m, n, i, j: integer; s: real; a: array[,] of real;
begin write('Введите S: '); read(s); write('Введите M, N: '); read(m, n); setlength(a, m + 1, n + 1); writeln('Введите элементы матрицы: '); for i := 1 to m do for j := 1 to n do read(a[i, j]); for i := 1 to m do begin for j := 1 to n do if a[i, j] <> s then begin writeln(a[i, j]); break; end; if a[i, j] = s then writeln('-'); end; end.
Программное обеспечение-это набор команд ,управляющих работой компьютера. Без программного обеспечения компьютер не сможет выполнять задачи, которые мы обычно связываем с компьютерами. функции программного обеспечения следующие: 1)управлять компьютерными ресурсами организации;2)обеспечивать пользователя всеми инструментами,необходимыми для извлечения пользы из этих ресурсов; 3)выполнять роль посредника между организациями и хранимой информацией ;выбор соответствующего потребностям организации программного обеспечения - одна из ключевых задач управляющего персонала
m, n, i, j: integer;
s: real;
a: array[,] of real;
begin
write('Введите S: ');
read(s);
write('Введите M, N: ');
read(m, n);
setlength(a, m + 1, n + 1);
writeln('Введите элементы матрицы: ');
for i := 1 to m do
for j := 1 to n do
read(a[i, j]);
for i := 1 to m do
begin
for j := 1 to n do
if a[i, j] <> s then
begin
writeln(a[i, j]);
break;
end;
if a[i, j] = s then
writeln('-');
end;
end.
Пример:
Введите S: 7
Введите M, N: 3 4
Введите элементы матрицы:
7 4 3 7
3 5 1 4
7 7 7 7
4
3
-
функции программного обеспечения следующие: 1)управлять компьютерными ресурсами организации;2)обеспечивать пользователя всеми инструментами,необходимыми для извлечения пользы из этих ресурсов; 3)выполнять роль посредника между организациями и хранимой информацией ;выбор соответствующего потребностям организации программного обеспечения - одна из ключевых задач управляющего персонала