В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
olcheymaaaa
olcheymaaaa
02.08.2020 18:49 •  Информатика

Используя цикл «for», написать программу на языке С++ для решения следующей задачи: Среди всех двузначных чисел найти количество таких, у которых сумма цифр кратна 3. Например, у числа 27 сумма цифр 2+7 = 9, т.е. кратна 3, а у числа 25 сумма цифр 2+5 = 7 не кратна 3. Определите, сколько чисел удовлетворяет задачи.

Показать ответ
Ответ:
baxitclash
baxitclash
16.04.2021 19:15

int sum = 0;

for (int i=10, i<=99, i++) {

if ((i%10 + i/10) % 3 == 0) {

sum += 1;

}

}

cout << sum;

Если есть вопросы по коду - пиши в комментарии

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота