Информатика. в ! «составить программу, которая формирует двумерную матрицу случайных чисел, имеющих n строк и n столбцов, а затем формирует два одномерных массива. причём в один записываются элементы матрицы, расположенные на главной диагонали и выше, а в другой - элементы матрицы, лежащие ниже главной диагонали и выводит все массивы на экран.» хоть кто-нибудь , ну всё запущено : (
Объяснение:
program matic1;
const z=100;
type mas=array[1..z] of integer;
type mas2=array[1..z,1..z] of integer;
var
u :mas2;
u1, u2: mas;
n,k,m:integer;
procedure ch1(n:integer);
var i,j:integer;
begin
j:=0;k:=0;m:=0;
randomize;
for i:=1 to n do
for j:=1 to n do
u[i,j]:= random(20+j)+20;
for i:=1 to n do
for j:=1 to n do
begin
if j>=i then begin k:=k+1;u1[k]:=u[i,j] end
else begin m:=m+1;u2[m]:=u[i,j] end;
end;
end;
// Вывод 2 мерного массива на экран
// a -массив n-размер,text - что хотим написать
procedure showmas2(b:mas2;n:integer;text:string);
var
i,j:integer;
begin
writeln(text);
for i:=1 to n do
for j:=1 to n do
if j<>n then write(b[i,j],' ') else writeln(b[i,j],' ');
readln;
end;
// Вывод 1 мерного массива на экран
// a -массив nn-размер,text - что хотим написать
procedure showmas(b:mas;nn:integer;text:string);
var
i:integer;
begin
writeln(text);
for i:=1 to nn do
write(b[i],' ');
readln;
end;
begin
Write('Введите размер массива N= ');
readln(n);
ch1(n);
showmas2(u,n,'Исходная матрица NxN u');
showmas(u1,k,'Элементы главной диагонали и выше u1');
showmas(u2,m,'Элементы ниже главной диагонали u2');
readln;
end.
end.