В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Danil24052002
Danil24052002
16.03.2021 15:45 •  Информатика

Информатика Составьте программу нахождения произведения всех натуральных чисел из диапазона от А до В, включая А и В, кратных 2 и 3 одновременно(А и В вводятся с клавиатуры).

Показать ответ
Ответ:
Gasdsa
Gasdsa
14.10.2020 21:00

program z1;

var i,a,b,p:integer;

begin

write('a = ');

readln (a);

write('b = ');

readln (b);

p:=1;

for i:=a to b do

if (i mod 2 = 0) and (i mod 3 =0) then p:=p*i;

if p <> 1 then writeln ('Произведение чисел, кратных 2 и 3 одновременно, равно ',p)

end.

Объяснение:

Если таких чисел нет, то программа ничего не выводит.

Если промежуток очень большой, то лучше изменить тип p (например, на real), чтобы не было переполнения.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота