В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
maxprok2012
maxprok2012
02.07.2020 08:04 •  Информатика

информатика

составьте программу для нахождения произведения 10 элементов массива (случайные числа от 0 до 10)​

Показать ответ
Ответ:
иринка244
иринка244
27.11.2020 23:52

const n=10;

var a:array[1..n] of integer;

i:integer; p:real;

begin

for i:=1 to n do read(a[i]);

p:=1;

for i:=1 to n do p:=p*a[i];

writeln('p = ',p);

end.

Пример:

4 6 2 3 8 1 4 7 9 1

p = 290304

0,0(0 оценок)
Ответ:
ArtemDigue
ArtemDigue
27.11.2020 23:52

var

 a : array[1..10] of integer;

 i, p : integer;

begin

 p := 1;

 for i := 1 to 10 do

 begin

   a[i] := round(random(11));

   Write(a[i], ', ');

   p := p * a[i];

 end;

 WriteLn();

 WriteLn('Произведение равно ', p);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота