Информатика python. написать программу 1. запросить пользователя ввести имя файла(файл содержит числа) если файл не существует - выдать ошибку,завершить программу 2. создать пустой список.прочитать файл.удалить \n значения.перевести все в вид integer. присоеденить форматированный файл к списку. если в строчке нет числа - пропустить и читать следующую строчку выписать наибольшее число списка.либо выдать ошибку о пустом списке. файл сохранить в формат csv. таким образом : (число; число - наибольшее значение списка)
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
using namespace std;
int Accum (const vector<int>& v) { // сумма цифр числа
int sum = 0;
for (auto x : v) {
sum += x;
}
return sum;
}
vector<int> NumInNums (const int& number) { // разбираем число на цифры
vector<int> Nums = {};
int num = number;
while (num != 0) {
Nums.push_back(num % 10);
num /= 10;
}
reverse(begin(Nums), end(Nums));
return Nums;
}
void Funct_1 (const int& number_2, const vector<int> nums) {
int Accumul = Accum(nums);
if (Accumul >= 10) { // проверка суммы на двузначность
cout << "Two-digit number" << endl;
} else {
cout << "Not a two digit number" << endl;
}
if (Accumul > number_2) { // больше или меньше, чем х
cout << "Exceeds" << endl;
} else {
cout << "Not exceed" << endl;
}
if (Accumul % 6 == 0) { // кратность суммы цифр шести
cout << "Multiple 6" << endl;
} else {
cout << "Not multiple 6" << endl;
}
}
void Funct_2(const vector<int>& v) {
if (v[v.size() - 2] > v[v.size() - 1]) { // сравнение цифры десятков с цифрой единиц
cout << "The number of tens more digits units" << endl;
} else {
cout << "The number of units is greater than the number of tens" << endl;
}
bool F = false;
for (auto x : v) { // входит ли цифра 4 или 7 в число
if ((x == 4) or (x == 7)) {
F = true;
break;
}
}
if (F == true) {
cout << "4 or 7 enters" << endl;
} else {
cout << "4 or 7 is not included in the number" << endl;
}
if (v[v.size() - 1] == 5) { // оканчивается ли число цифрой 5
cout << "Ends with the number 5" << endl;
} else {
cout << "Not end in 5" << endl;
}
}
int main() {
int number_1, number_2;
vector<int> nums;
cout << "Number a: ";
cin >> number_1;
cout << "Number x: ";
cin >> number_2;
Funct_1(number_2, NumInNums(number_1));
Funct_2(NumInNums(number_1));
return 0;
}
Арифметр:144425144725144633144729144644144646144644144630144727144725(10 система)
000011100010110000011001000011100010111100011001000011100010111000100001
0000111000101111000111010000111000101110001011000000111000101110001011100
0001110001011100010110000001110001011100001111000001110001011110001101100
0011100010111100011001(2 система)
Перфокарта:144447144630144725144729144646144642144625144725144727144625(10 система)
000011100010110000101111000011100010111000011110000011100010111100011001
0000111000101111000111010000111000101110001011100000111000101110001010100
0001110001011100001100100001110001011110001100100001110001011110001101100
0011100010111000011001(2 система)
Программа:144447144725144646144628144725144625144644144644144625(10 система)
000011100010110000101111000011100010111100011001000011100010111000101110
0000111000101110000111000000111000101111000110010000111000101110000110010
00011100010111000101100000011100010111000101100000011100010111000011001(2 система)