В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruevtop
ruevtop
05.03.2023 15:05 •  Информатика

Информатика, программирование на языке Паскаль, нужно написать программу. Определить сколько платьев можно сшить из 100 м ткани. На платье уходит 80% роста. Рост 155-180.
Примерно должно выглядеть вот так, как указано на картинке.


Информатика, программирование на языке Паскаль, нужно написать программу. Определить сколько платьев

Показать ответ
Ответ:
lizagolovashko
lizagolovashko
25.03.2023 22:56

1)многофункциональное электронное програмно управляемое устройство для работы с информацией

2)сканер

3)тактовой частоты процессора

4)Программа - это последовательность… *

команд для компьютера

5)внешняя память

6)в двоичном коде

7)Принтер - устройство кодирования

8)Операционная система - это программы, управляющие работой компьютера

9)программа, обеспечивающая работу устройства компьютера

10)а) программа для обработки информации без знания программирования

11)г) в оперативной памяти

12)аппаратным интерфейсом

13)в) рисунков и фотографий

14)пользовательский интерфейс

15)Логический диск

16)вредоносная программа нанести ущерб данным на копьютере или вывести его из стро

17)Графическим файлам

18)Один любой допустимый символ

19)C

20)Файловая система

21)клавиатура, джойстик,монитор,мышь

22)C:\Работа1

23)-

24)-

25)расширение

0,0(0 оценок)
Ответ:
GizaHelinc
GizaHelinc
13.01.2020 17:23

Описание алгоритма:

Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы(так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны):

1) Заканчиваются на 0.

2) Ровно на одну единицу

3) Ровно на две единицы.

Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т.к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для N=1 и N=2 также работает правильно.

Программа на Pascal:

var num00,num01,num11,mem00:integer;

   n,i:byte;

begin

readln(n);

 num00:=1;

 for i:=1 to n do begin

   mem00:=num11;

   num11:=num01;

   num01:=num00;

   num00:=num01+num11+mem00;

 end;

writeln(num11+num01+num00);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота