Информатика ( Программирование ) - 7 класс Даны два целых числа A и B. Напишите программу без использования условного оператора "if", которая выводит все нечетные числа на отрезке от А до B. ( Программа должна быть написана на C++ ).
Входные данные:
На вход программе подаются два целых числа A и B (A≤B), по одному в строке.
Выходные данные:
Вывести через пробел все нечетные числа на заданном отрезке.
Пример:
Входные данные: (A = 1; B = 10)
Выходные данные: (1 3 5 7 9)
f: file of integer;
i, n, x, t, k, max: integer;
s: integer;
begin
randomize;
write('n=');
readln(n);
assign(f, 'numbers.dat');
rewrite(f);
max := -1;
for i := 1 to n do
begin
x := random(4800) + 20;
write(f, x);
write(x, ' ');
if x > max then max := x;
end;
writeln;
seek(f, 0);
k := 0;
while not eof(f) do
begin
read(f, x);
t := x;
s := 0;
while t > 0 do
begin
s := s + sqr(t mod 10);
t := t div 10;
end;
if x mod s = 0 then k := k + 1;
if x > max - 50 then write(x, ' ');
end;
writeln;
writeln(k);
end.
N = 10;
var
A: array[1..N] of integer;
function Fun: integer;
var
i, M: integer;
begin
writeln('Введите число M=');
readln(M);
for i := 1 to N do
if A[i] = M then Fun := i;
end;
procedure CreateMassive;
var
i: integer;
begin
for i := 1 to N do
begin
A[i] := Random(199) - 100;
write(A[i],' ');
end;
Writeln;
end;
begin
CreateMassive;
Writeln(Fun);
end.
вот вариант исправления который работает, хотя конечно не факт что он работает как там кто-то задумывал)))
не понятно было назначение функции Fun потому она делает поиск номера элемента равного М
а вообще глобальные переменные это зло. Так что проектирование тут в корне не верно