В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
maria20061970
maria20061970
26.05.2023 04:52 •  Информатика

Информатика, паскаль напишите программу, перемещающую все нулевые элементы в конец массива 80 очков,

Показать ответ
Ответ:
sanek15604
sanek15604
27.08.2020 12:13

const n = 10;

var

 mas: array [1..n] of integer;

 i,j,h:integer;

begin

randomize;

for i := 1 to n do

 begin

   mas[i] := random(3);

   write(' ',mas[i],' ');

 end;

 writeln();

for i := 1 to n - 1 do

 for j := 1 to n - i do

   if(mas[j] = 0) then

     begin

       h := mas[j];

       mas[j] := mas[j + 1];

       mas[j + 1] := h;

     end;

for i := 1 to n do

   write(' ',mas[i],' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота