В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kjhgfffdpavel
kjhgfffdpavel
20.05.2020 02:47 •  Информатика

информатика
Напишите программу вычисления выражений:

а) y
cosx, x ≤ 0
3sin 2x + 5, x ≥ 2
tgx – 21,5x + 1, 0 < x < 2
б) y
31,5x + 5, x ≤ 0
2tgx + 1, x ≥ 2
x2 + x + 1, 0 < x < 2
в) y
cosx, π
8
< x < π
6
sin2x + 3cosx, x ≥ π
6
5,6 + 2tg2x, x ≤ π
8

Показать ответ
Ответ:
ficusborislav
ficusborislav
20.04.2020 01:42
Сумма средних цифр может быть равна числу от 0 до 18
сумма крайних цифр может быть равна числу от 1 до 18 (т.к. ерайняя левая цифра не может быть равна нулю, потому тто в противном случае это было бы уже не 4х значное число. Например: 0123)

Так же получившиеся 2 новых числа не могут начинаться с нуля.

Порядок не убывания, значит второе число больше или равно первому.

число 101 могло быть составлено только из 10 и 1, но 1 < 10, значит они расположены в порядке убывания, это нам не подойдёт

20 составлено из 2 и 0, тоже порядок убывания, не подходит

312 составлен либо (3 и 12), либо (31 и 2), но наши два числа не могут быть больше 18 (т.к десятичные цифры от 0 до 9) Значит 312 составлен из 3 и 12 - подходит

Аналогично 1312 состоит из 12 и 13, подходит, т.к 13 >= 12 (пример исходного числа 6766) 

А вот 1312 не подойдёт, т.к 12 < 13

1212 - подходит т.к. 12 >= 12 (пример исходного 6666)

112 - это либо 1 и 12, либо 11 и 2. Второй вариант отсекаем, первый подходит (например 1660)

1012 - подходит

ответ: может получиться 5 чисел из приведенных
0,0(0 оценок)
Ответ:
Kosmen21
Kosmen21
16.08.2021 09:27
#include <iostream>
#include <string>

using namespace std;

int main()
{
    string S;
    cin >> S;
    int Mass[52];
    for (int i = 0; i < 52; i++)
    {
        Mass[i] = 0;
    }
    for (int i = 0; i < S.length(); i++)
    {
        char c = S[i];
        if (c >= 'a'&&c <= 'z')
        {
            Mass[(int)(c-'a')*2]++;
        } else if (c >= 'A'&&c <= 'Z'){
            Mass[(int)(c-'A')*2+1]++;
        }
    }
    for (int i = 0; i < 52; i++)
    {
        for (int j = 0; j < Mass[i]; j++)
        {
            cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
        }
    }
    return 0;
}

Пример работы программы:
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота