В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ketivolkowa
ketivolkowa
23.04.2022 11:31 •  Информатика

Информатика 9 класс. составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов, которые больше своего соседа справа. пример вывода: исходный массив: 10 2 4 1 3 5 7 8 2 7 количество элементов, которые больше своего соседа справа=3 буду

Показать ответ
Ответ:
Dogerman11
Dogerman11
02.10.2020 04:13
Const   N=10;
var   a:array [1..N] of integer;   
      k,i:integer;
begin 
randomize; 
for i:=1 to N do  
    begin 
    a[i]:=random(10)+1; 
    write (a[i], ' '); 
end; 
for i:=1 to N-1 do  
   if a[i]>a[i+1] then k:=k+1;  
writeln('k= ', k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота