В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
karimjan96961
karimjan96961
26.07.2020 02:44 •  Информатика

Информатика 8 класс. Буду благодарен) Напишите программу и загрузите код программы в качестве ответа.
Дано натуральное число n. Определите, сколько у него различных натуральных делителей, включая число 1 и само число n.
ВХОДНЫЕ ДАННЫЕ
Программа получает на вход одно целое число n, 1⩽n⩽109.
ВЫХОДНЫЕ ДАННЫЕ
Программа должна вывести количество различных натуральных делителей числа n.
ПРИМЕР
ввод вывод
1 1
10 4
24 8

Показать ответ
Ответ:
алиса673
алиса673
23.02.2023 15:23

def print_digit_sum(a):

 print(f'Сумма цифр числа {a} равна {sum([int(i) for i in str(a)])}')

while True:

 try:

   print_digit_sum(int(input('Введите целое число:')))

   break

 except ValueError:

   print('Неверный формат входных данных')

sum([int(i) for i in str(a)]) - здесь мы выполняем следующие действия:

1. Преобразуем число в строку с str(a)

2. Пробегаемся по символам строки от первого до последнего и создаём массив, преобразуя каждый строковый символ в число - [int(i) for i in str(a)]

3. Ну и наконец с оператора sum вычисляем сумму всех элементов получившегося массива

0,0(0 оценок)
Ответ:
MrWolf1244
MrWolf1244
21.04.2022 17:14
На Java:

class SearchPalin{
 public static void main(String args[]){
  String palinString = new java.util.Scanner(System.in).nextLine();
  System.out.print("\nПалиндром(-ы):\n  ");
  for(int wordStart = 0, wordEnd = 0; wordEnd<palinString.length(); wordEnd++)
   if(wordEnd+1==palinString.length() || palinString.charAt(wordEnd+1)==' '){
 String wordBeginning = "", wordEnding = "";
 for(int wordBe = wordStart;wordBe<wordEnd+1;wordBe++)wordBeginning+=palinString.charAt(wordBe);
 for(int wordEn = wordEnd;wordStart-1<wordEn;wordEn--)wordEnding+=palinString.charAt(wordEn);
 if(wordBeginning.equals(wordEnding)){
  for(int palinWord = wordStart;palinWord<=wordEnd;palinWord++)System.out.print(palinString.charAt(palinWord));
  System.out.print("\n  ");
 } wordStart = wordEnd+2;
   }
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота