В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dulat15
dulat15
18.04.2020 07:48 •  Информатика

Информатика.10 класс задачи на циклы. ПАСКАЛЬ

1. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности N, а затем сами числа. Программа должна вывести одно число — сумму чисел, кратных 3. Пример работы программы:
Входные данные: 3, 12, 25, 9
Выходные данные: 21.

2. Напишите программу, которая позволяет вычислить все значения функции y=2х +4 для ) 5;2( x с шагом 0,5. Программа должна вывести таблицу значений x,y.

3. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0. Программа должна вывести одно число: количество всех чётных чисел, кратных 9.
Входные данные: 27,24,18,22,36,0
Выходные данные:2

4.Напишите программу, которая определяет количество нечетных цифр в числе N. Программа получает на вход число N (N описывается типом longint). Программа должна вывести одно число – количество нечетных цифр числа. Пример работы программы:
Входные данные: 12564
Выходные данные: 2

Показать ответ
Ответ:
pocemonpickachu
pocemonpickachu
13.01.2023 10:46

PascalВыделить код

1

2

3

4

5

6

7

8

9

10

11

12

var s:string;

len,i,n:integer;

begin

write ('Введите строку:'); readln (s);

write ('введите N:'); readln(n);

len:=length(s);

if len>n then s:=copy (s,len-n+1,len-n)

else if len<n then for i:=len+1 to n do insert('.',s,1);

writeln ('Итоговая строка: ');

write (s);

readln;

end.

Введите строку:qwertyuiopa

введите N:5

Итоговая строка:

uiopa

Введите строку:abrik

введите N:10

Итоговая строка:PascalВыделить код

1

2

3

4

5

6

7

8

9

10

11

12

var s:string;

len,i,n:integer;

begin

write ('Введите строку:'); readln (s);

write ('введите N:'); readln(n);

len:=length(s);

if len>n then s:=copy (s,len-n+1,len-n)

else if len<n then for i:=len+1 to n do insert('.',s,1);

writeln ('Итоговая строка: ');

write (s);

readln;

end.

Введите строку:qwertyuiopa

введите N:5

Итоговая строка:

uiopa

Введите строку:abrik

введите N:10

Итоговая строка:

0,0(0 оценок)
Ответ:
gloria81
gloria81
03.01.2022 20:20

Объяснение:

1. Пронумеруем разряды:

3-й разряд - 4;

2-й разряд - 1;

1-й разряд - 5;

0-й разряд - 3.

4153₈=4·8³+1·8²+5·8¹+3·8⁰

2. 4153₈=4·8³+1·8²+5·8¹+3·8⁰=2048+16+40+3=2155₁₀

3. 125/8=15 (5)

15/8=1 (7)

(1)

125₁₀=175₈

4. Пронумеруем разряды:

2-й разряд - A;

1-й разряд - 6;

0-й разряд - E;

A6E₁₆=(10)(6)(14)=10·16²+6·16¹+14·16⁰

5. A6E₁₆=10·16²+6·16¹+14·16⁰=2560+96+14=2670₁₀

6. 350/16=21 (14=E)

21/16=1 (5)

(1)

350₁₀=15E₁₆

7. 247/2=123 (1)

123/2=61 (1)

61/2=30 (1)

30/2=15 (0)

15/2=7 (1)

7/2=3 (1)

3/2=1 (1)

(1)

247₁₀=11110111₂

247/8=30 (7)

30/8=3 (6)

(3)

247₁₀=367₈

247/16=7 (15=F)

(7)

247₁₀=7F₁₆

Получившиеся числа между собой равны, так как имеют одинаковое число в десятичной системе счисления.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота