В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SolkePT
SolkePT
01.11.2022 12:14 •  Информатика

Инфа напишите код на python, плз Летом, в Ялте, ученики стоят в очереди за мороженным. Известно, что в очереди стоит N учеников. Каждый в очереди планирует купить себе одно мороженное. Как правило, но не всегда, два мороженных в одни руки продавец продаёт быстрее, чем одно. Поэтому некоторые из учеников решили объединиться в пары. Объединиться в пару могут только рядом стоящие ученики, чтобы не была нарушена очередность продажи мороженного, при этом мороженное на объединившихся в пары учеников всегда покупает тот, кто стоял первым из них.
Известно, что на продажу i-му ученику из очереди одного мороженного продавец потратит Xi секунд, на продажу двух мороженных — Yi секунд. Напишите программу, которая подсчитает минимальное время, за которое могут быть обслужены все покупатели.
Со стандартного потока ввода сначала считывается число N (1 ≤ N ≤ 10000) — количество покупателей. Далее в N строках вводятся пары целых неотрицательных чисел Xi, Yi. (1 ≤ Xi, Yi ≤ 100) -время обслуживания для каждого покупателя. Где первая пара чисел – это время обслуживания первого ученика в очереди, вторая пара – время обслуживания второго ученика в очереди и т.д.
Требуется вывести минимальное время в секундах, за которое могут быть обслужены все покупатели.

Показать ответ
Ответ:
poloch
poloch
02.05.2021 21:50

Не очень уверен в правильности данного решения, потестил немного на разных вариантах - вроде работает. Но ощущение, что какой-то он корявый...

n = int(input('Введите количество учеников: '))

a = [list(map(int, input(f'Введите 1<=Xi и Yi<=100 через пробел для {i+1}-го ученика: ').split())) for i in range(n)]

print(a)

i = 0

summ = 0

while i <= len(a)-1:

   if i < len(a)-2:

       if a[i][1] < a[i+1][1]:

           summ += a[i][1]

           i += 2

       else:

           summ += a[i][0]

           i += 1

   elif i == len(a)-2:

       summ += a[i][1]

       i += 2

   else:

       summ += a[i][0]

       i += 1

print(summ)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота