В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nicesasha2017
nicesasha2017
22.05.2023 17:27 •  Информатика

Инфа.
3. Выполнить задание. Напишите программу, которая вводит данные в многомерный массив размером 4 на 3 и имеет вид:
1 1 1 1
2 2 2 2
3 3 3 3​

Показать ответ
Ответ:
228даша228
228даша228
21.04.2023 20:06

В одной из кодировок Unicode каждый символ кодируется 16 битами. При подготовке реферата по биологии Вова написал следующий текст (в нём нет лишних пробелов).

 

«Як, тар, лама, окапи, пекари, бегемот, антилопа, бабирусса, бородавочник относятся к диким парнокопытным животным».

 

Затем Вова вычеркнул из списка название одного из животных. Заодно он вычеркнул ставшие лишними запятые и пробелы — два пробела не должны идти подряд. При этом размер нового предложения в данной кодировке оказался на 16 байт меньше, чем размер исходного предложения. Напишите в ответе вычеркнутое название животного.

Решение.

Поскольку один символ кодируется двумя байтами, из текста удалили 8 символов. Заметим, что лишние запятая и пробел занимают четыре байта. Значит, название животного, которое удалили из списка, должно состоять из шести букв, поскольку (16 − 4) : 2 = 6 символов. Из всего списка только одно название животного состоит из 6 букв — пекари.

 

ответ: пекари.

Объяснение:

0,0(0 оценок)
Ответ:
minion19
minion19
23.03.2020 08:48

1) Код программы:

const N = 10;

var a:array[1..N] of integer;

i:integer;

begin

 writeln('Массив:');

 for i:=1 to N do begin

   a[i] := random(-100, 100);

   write(a[i], ' ');

 end;

 writeln();

 writeln('Отрицательные элементы, кратные 3: ');

  for i:=1 to N do begin

   if ((a[i] < 0) and (a[i] mod 3 = 0)) then

     write(a[i], ' ');

 end;

end.

2) Код программы:

const N = 8;

var a:array[1..N] of integer;

i, sum:integer;

begin

 writeln('Массив:');

 for i:=1 to N do begin

   a[i] := random(-100, 100);

   write(a[i], ' ');

 end;

 sum:=0;

 writeln();

 writeln('Сумма нечётных элементов, больше 10: ');

  for i:=1 to N do begin

   if ((a[i] > 10) and (a[i] mod 2 = 1)) then

     sum:= sum + a[i];

 end;

 write(sum);

end.

3) Код программы:

const N = 10;

var a:array[1..N] of integer;

i, kol:integer;

begin

 writeln('Массив:');

 for i:=1 to N do begin

   a[i] := random(-5, 5);

   write(a[i], ' ');

 end;

 kol:=0;

 writeln();

 writeln('Количество элементов, равных нулю с чётными индексами: ');

  for i:=1 to N do begin

   if ((a[i] = 0) and (i mod 2 = 0)) then

     kol:= kol + 1;

 end;

 write(kol);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота