В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
2001kirik
2001kirik
04.09.2021 12:40 •  Информатика

Ине нужно писать просто так, только программу. массив из 8 элементов содержит оценки за четверть. заполнение его организовать с клавиатуры. написать программу, которая вычислит четвертную оценку и выведет ее на экран. для этого будет необходимо: 1. найти сумму элементов массива. 2. посчитать среднее арифметическое оценок – x. 3. округлить х до отметки. правило, как выставляются оценки за четверть: 0

Показать ответ
Ответ:
Var
s, i: integer;
x:real;
mas: array [1..8] of integer;
begin
s:=0;
for i:=1 to 8 do
begin
readln (mas[i]);
s:=s+mas[i];
end;
x:=s/8;
If (x>0) and (x<2.49) then write ('2');
If (x>=2.5) and (x<=3.49) then write ('3');
If (x>=3.5) and (x<=4.49) then write ('4');
If (x>=4.5) and (x<=5) then write ('5');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота