В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vanita111106
Vanita111106
15.11.2021 08:26 •  Информатика

ИКТ
Написать программу на Паскаль: Дан массив из 10 целых чисел, заполненный генератором случайных чисел [-15;19], отсортировать данный массив любым по возрастанию.

Показать ответ
Ответ:
oldespower
oldespower
03.01.2023 03:04
В общем случае, трассировка - один из отладки программ врукопашную: состояние программы контролируется на определённом отрезке времени её выполнения путём анализа значений переменных. трассировка в том или ином виде при отладке программ сложнее школьного дз практически неизбежна.
в простейшем случае, трассировка - вывод значений переменных на экран (например, в окно консоли) , либо расчёт их на бумажке для каждого шага.
в более продвинутом варианте используются точки останова, окно наблюдения, выполнение по шагам и, если есть, контекстный интерпретатор выражений.
есть также специальная "трассирующая консоль" - интерфейс вывода информации из программы в отладчик, если таковой присутствует.
почти любой современный отладчик показывает состояние програмm при её останове, что делает трассировку процессом легко доступным
0,0(0 оценок)
Ответ:
shantropa33
shantropa33
16.05.2022 04:37

using System;

     

public class Program

{

public static void Main()

{

 var rand = new Random();

 int x = rand.Next(3, 10);

 int t = 1200;

 int count;

 if (t % x == 0)

 {

  count = t / x;

 }

 else

 {

  count = t / x + 1;

 }

 int ans;

 if (count % 20 == 0)

 {

  ans = count / 20;

 }

 else

 {

  ans = count / 20 + 1;

 }

 Console.WriteLine(ans.ToString());

}

}

Генерируем рандомное число от 3 до 10. Затем рассчитаем на сколько лекций он опоздает суммарно на 20 часов (т.е. 1200 минут). Разделим количество лекций, на которые он опоздал, на 20 с округлением вверх и получим ответ.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота