В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
iobolenkov
iobolenkov
05.12.2022 09:44 •  Информатика

Free pascal. нужно написать программу, где после каждой буквы ch вставляется строка str1.

Показать ответ
Ответ:
мэри114
мэри114
03.10.2020 01:12
Var
  s,str1:string;
  ch:char;
  i:integer;
begin
  Write('Введите текст: '); ReadLn(s);
  Write('Введите искомый символ: '); Readln(ch);
  Write('Введите добавляемый текст: '); Readln(str1);
  for i:=Length(s) downto 1 do
    if s[i]=ch then Insert(str1,s,i+1);
  Writeln('Результат: ',s);
  Readln;
end.

Тестовое решение:
Введите текст: А роза упала на лапу Азора
Введите искомый символ: а
Введите добавляемый текст: 12345
Результат: А роза12345 упа12345ла12345 на12345 ла12345пу Азора12345
0,0(0 оценок)
Ответ:
Tomkaya
Tomkaya
03.10.2020 01:12
program Project4;
var ch:char; str,str1,str2:string; i:integer;
begin
    writeln('Введите исходный текст:');
    readln(str);
    writeln('Введите строку которую нужно вставить:');
    readln(str1);
    writeln('Введите символ после которого нужно вставить:');
    readln(ch);
    str2:='';
    i:=pos(ch,str);
    while i>0 do begin
      str2:=str2+copy(str,1,i)+str1;
      delete(str,1,i);
      i:=pos(ch,str);
    end;
    writeln('Результирующая строка: ',str2);
        readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота