В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vasilevamarin
vasilevamarin
03.12.2021 11:46 •  Информатика

Энаписать программу для решения : что больше n метров или m сантиметров. на вход программе два числа n - метров и m - сантиметров, программа должна вывести одно наибольшее число.

Показать ответ
Ответ:
kristinarepina
kristinarepina
13.09.2022 22:29

cnt = 0 # количество чисел в последовательности

mean = 0 # среднее значение последовательности

mod3 = 0 # количество чисел, делящихся на 3

mod3_7 = 0 # количество чисел, делящихся на 3, но не делящихся на 7

cnt2 = 0 # количество двузначных чисел

cnt2_3 = 0 # количество двузначных чисел, оканчивающихся на 3

maxx = None # максимальное число

maxx_mod2 = None # максимальное из чётных

maxx2 = None # второй максимум

maxmin = None # разница между максимальным и минимальным

a = int(input('Введите целое число: '))

while a != 0:

   cnt += 1

   mean += a

   if abs(a)%3 == 0: mod3 += 1

   if abs(a)%3 == 0 and abs(a)%7 != 0: mod3_7 += 1

   if abs(a)//10 != 0 and abs(a)//100 == 0: cnt2 += 1

   if abs(a)//10 != 0 and abs(a)//100 == 0 and abs(a)%10 == 3: cnt2_3 += 1

   if maxx is None or a > maxx: maxx = a

   if abs(a)%2 == 0 and (maxx_mod2 is None or a > maxx_mod2): maxx_mod2 = a

   if a < maxx and (maxx2 is None or maxx2 < a): maxx2 = a

   if maxmin is None or a < maxmin: maxmin = a

   a = int(input('Введите ещё одно целое число или 0 для завершения: '))

print()

print('- количество чисел в последовательности:', cnt)

if cnt != 0:

   print('- среднее значение последовательности:', round(mean/cnt,2))

   print('- количество чисел, делящихся на 3:', mod3)

   print('- количество чисел, делящихся на 3, но не делящихся на 7:', mod3_7)

   print('- количество двузначных чисел:', cnt2)

   print('- количество двузначных чисел, оканчивающихся на 3:', cnt2_3)

   print('- максимальное число:', maxx)

   print('- максимальное из чётных:', maxx_mod2)

   print('- второй максимум:', maxx2)

   print('- разница между максимальным и минимальным:', maxx - maxmin)

То же самое, но с массивом и лямбда-функциями:

values = []

a = int(input('Введите целое число: '))

while a != 0:

   values.append(a)

   a = int(input('Введите ещё одно целое число или 0 для завершения: '))

print()

print('- количество чисел в последовательности:', len(values))

if len(values) != 0:

   print('- среднее значение последовательности:', round(sum(values)/len(values), 2))

   print('- количество чисел, делящихся на 3:', len(list(filter(lambda x: abs(x)%3 == 0, values

   print('- количество чисел, делящихся на 3, но не делящихся на 7:', len(list(filter(lambda x: abs(x)%3 == 0 and abs(x)%7 != 0, values

   print('- количество двузначных чисел:', len(list(filter(lambda x: abs(x)//100 == 0 and abs(x)//10 != 0, values

   print('- количество двузначных чисел, оканчивающихся на 3:', len(list(filter(lambda x: abs(x)//100 == 0 and abs(x)//10 != 0 and abs(x)%10 == 3, values

   print('- максимальное число:', max(values))

   print('- максимальное из чётных:', max(list(filter(lambda x: abs(x)%2 == 0, values

   print('- второй максимум:', max(list(filter(lambda x: x<max(values), values

   print('- разница между максимальным и минимальным:', max(values) - min(values))

0,0(0 оценок)
Ответ:
Katemur20
Katemur20
22.07.2020 14:56

С элементов управления на данной вкладке вы можете:

• менять текущий режим отображения слайдов: Обычный (Normal), Сортировщик слайдов (Slide Sorter), Страницы заметок (Notes Page), Режим чтения (Reading View) — см. раздел «Режимы просмотра слайдов»;  

• использовать и создавать образцы оформления: Образец слайдов (Slide Master), Образец выдач (Handout Mater), Образец заметок (Notes Master) — см. раздел «Вкладки для работы с образцами документов»;  

• отображать дополнительные элементы для выравнивания объектов на слайде: вертикальную и горизонтальную линейки , сетку, направляющие. Для этого установите соответствующие флажки;  

• устанавливать удобный масштаб отображения с команд Масштаб (Zoom) и Вписать в окно (Fit to Window);

• устанавливать цветовую гамму слайдов, выбрав один из вариантов: Цвет (Color), Оттенки серого (Grayscale), Черно-белый (Black and White). Данная возможность полезна при необходимости распечатать цветную презентацию на черно-белом принтере;

• упорядочивать представления для открытых файлов PowerPoint с команд группы Окно (Window);  

• открывать список макросов для их выполнения, создания и удаления, щелкнув по кнопке Макросы (Macros).  

Макрос служит для автоматизации работы и представляет собой набор одновременно выполняемых команд и инструкций.  

Режимы просмотра слайдов

В программе PowerPoint существуют следующие режимы просмотра слайдов: Обычный, Сортировщик слайдов, Страницы заметок, Режим чтения. Чтобы перейти в любой из перечисленных режимов, на вкладке Вид щелкните по одной из кнопок в группе Режимы просмотра презентации (Presentation views). В зависимости от установленного режима изменяется вид окна презентации и компоновка его базовых элементов. Знакомство с интерфейсом программы PowerPoint 2010 31 Режимы просмотра предназначены для более удобной работы со слайдами на разных этапах создания презентации.

Обычный — это основной режим, в котором создаются и редактируются все слайды, составляющие презентацию. В данном режиме вы работаете с каждым слайдом отдельно: вводите текст, вставляете рисунки, графики, таблицы (рис. 2.12).

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота