В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
simone1311
simone1311
09.04.2023 18:36 •  Информатика

Егэ.27. информатика. надо написать программу на 4 . условие. последовательность на спутнике «восход» установлен прибор, предназначенный для измерения солнечной активности. каждую минуту прибор передаёт по каналу связи неотрицательное целое число – количество энергии солнечного излучения, полученной за последнюю минуту, измеренное в условных единицах. временем, в течение которого происходит передача, можно пренебречь. необходимо найти в заданной серии показаний прибора максимальное чётное произведение двух показаний, между моментами передачи которых не менее 9 минут. если получить такое произведение не удаётся, ответ считается равным –1. количество энергии, получаемое прибором за минуту, не превышает 1000 условных единиц. общее количество показаний прибора в серии не превышает 10 000. мое решение var n, i, j, d, max: integer; a: array[1..9] of integer; begin readln(n); max : = -1; for i : = 1 to 9 do readln(a[i]); for i : = 10 to n do begin readln(d); if a[1] mod 2 = 0 then begin if a[1] * d > max then max : = a[1] * d end else if d mod 2 = 0 then if a[1] * d > max then max : = a[1] * d; for j : = 1 to 8 do a[j] : = a[j + 1]; a[9] : = d; end; writeln(max) end. потянет ли это решение на 4 ? если нет, что можно улучшить.

Показать ответ
Ответ:
ввіна
ввіна
15.09.2020 02:10

Дано:

V = 512 Кбайт

Р = 640 ×480 пикс

N1=16 цв

N2  =256 цв

Найти:

S1 -?

S2 - ?

1) Найдем количество пикселей в изображении:

P = 640 ×480 = 307200 пикселей в изображении видеопамяти

2) Найдем глубину кодирования 1 пикселя

N = 2^i, где i - глубина кодирования 1 пикселя (количество ячеек памяти, предназначенных для 1 точки экрана)

16 = 2^4

i1 = 4 бит - глубина кодирования 1 пикселя при использоывании 16 цветов

256 = 2^8

i2 = 8 бит - глубина кодирования 1 пикселя при использоывании 256 цветов

 

3) Найдем объемы памяти нужные для хранения 1 страницы изображения:

V1 = i1 × P = 4 × 307200 = 1228800 бит = 153600 байт = 150 Кбайт - займет одна страница изображения при палитре в 16 цветов

V2 = i2 × P = 8 × 307200 = 2457600 бит = 300 Кбайт - займет одна страница изображения при палитре в 256 цветов

 

4) Посчитаем, сколько поместиться страниц экрана при разных палитрах:

512/150  = 3, 4 страницы, если палитра 16 цветов

512/300 = 1,7 страницы, если палитра 258 цветов

ответ:3,4 стр при палитре в 16 цветов

1,7 страницы при палитре в 256 цветов.

0,0(0 оценок)
Ответ:
malina20023
malina20023
02.06.2020 21:02
');
    else writeln('вы должны ввести число от 1 до 11')
  end;
  writeln('');
end.

 

 

 

program Phone;
var day:integer; time:real; week:array[1..7] of string;
begin
  week[7]:='Воскресенье';
  week[6]:='Суббота';
  week[5]:='Пятница';
  week[4]:='Четверг';
  week[3]:='Среда';
  week[2]:='Вторник';
  week[1]:='Понедельник';
  write('введите длительность разговора в минутах ');
  readln(time);
  write('введите номер дня недели ');
  readln(day);
  writeln(' alphaeus is thinking...  ');
  case day of
    '1'..'5':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Скидка не предоставляется');
       end;
    '6','7':
       begin
         writeln(week[day]);
         writeln('Сумма без скидки - ', 2.3*time);
         writeln('Сумма скидкой - ', 0.8*2.3*time);
         writeln('Вам предоставлена скидка!');
       end;
    else writeln('вы ввели неправильный номер дня недели')
  end;
  writeln'');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота