В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kamely98
kamely98
05.05.2021 07:01 •  Информатика

(двумерные массивы): В задаче введите размерности массива N и M в диалоговом режиме, распределите память под массив динамически, заполните матрицу случайными числами и выведите полученную матрицу. Если в результате должен получиться массив, то память под него также следует распределить динамически:

Для матрицы A(N, M) (N <= 15, M <= 10) найдите минимальные элементы каждой строки. Сформируйте массив B из найденных элементов.

Показать ответ
Ответ:
1NICOLAS1
1NICOLAS1
11.11.2021 09:26

#include <iostream>

int gg(int k, int p, double m)

{

p = (k >= p) ? p : p / k;

return (m * 2 * p);

}

int main()

{

int k, p;

double m;

std::cout << "Сколько котлет можно одновременно положить на сковороду ? ";

std::cin >> k;

std::cout << "Сколько минут жарится одна сторона котлеты ? ";

std::cin >> m;

std::cout << "Сколько котлет вы будете жарить ? ";

std::cin >> p;

std::cout << p << " котлет пожарятся с двух сторон минимум за " << gg(k, p, m) << " минут";

}

0,0(0 оценок)
Ответ:
alexandra2981278247
alexandra2981278247
23.09.2022 15:33
Const n=20;
type omas=array[1..n] of integer;
Procedure Del (var z:omas; k:byte); 
var i:byte; 
begin 
for i:=k to n-1 do z[i]:=z[i+1]; 
z[n]:=0; 
end; 
var a:omas; i,b:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
b:=6;
i:=1;
while (i<=n)and(a[i]<>b) do i:=i+1;
if i<=n then
  begin
  Del(a,i);
 writeln('Размерность массива = ',n-1);
 for i:=1 to n-1 do write(a[i]:4);
 writeln;
 end  else writeln('Массив не изменился');
end.
Пример:
  12  13   6   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
Размерность массива = 19
  12  13   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота