В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
polinaandreeva10
polinaandreeva10
10.01.2023 16:33 •  Информатика

Двумерные массивы. сам.работа вар.2 с-14 1.составьте программу вычисления суммы отрицательных элементов матрицы a(n,n) 2.составьте программу вычисления произведения положительных элементов матрицы b(n,n) 3.cоставьте программу
вычисления суммы элементов третьего столбца матрицы с(n,n) решите (

Показать ответ
Ответ:
Andezia
Andezia
24.05.2020 02:49

var a,b,c:array [1..100,1..100] of integer;

as,bs,cs,i,j:integer;

Begin

  sb:=1;

  for i := 1 to n do

     for j:= 1 to n do

     begin

       if a[i,j]<0 then sa:=sa+a[i,j];

       if b[i,j]>0 then sb:=sb*b[i,j];

       if j=3 then sc:=sc+c[i,j];

     end;

   writeln(sa,sb,sc);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота