В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aygul081071
aygul081071
15.10.2022 18:53 •  Информатика

Движение шарика в замкнутом объеме.

напишите программу моделирования движения шарика в замкнутом объеме на языке c, используя библиотеку “txlib.h”.
движение равномерное прямолинейное (законы выполняются). соударения со стенками . трением пренебречь.

в программе смоделируйте движение трёх шариков. соударениями пренебречь.

выход из программы по нажатию кнопки esc.

Показать ответ
Ответ:
Mtzv17
Mtzv17
04.01.2020 12:14
Прога написанная в codeblocks: #include < iostream> using namespace std; int main() {          setlocale(lc_all,"russian");           int a[20];           int b, c, i, q=0;           for(i=1; i< 21; i++)          {                  cout< < "введите "< < i< < " число: ";                   cin> > a[i];           }          cout< < "введите начальный номер элемента массива: ";     cin> > b;     cout< < "введите конечный номер элемента массива: ";     cin> > c;     for(int j=b; j< c+1; j++)          {                q+=a[j];         }          cout< < "cумма элементов массива с номерами с "< < b< < " по "< < c< < " равна: "< < q; } я надеюсь тебе была нужна прога на с++))
0,0(0 оценок)
Ответ:
Onewood
Onewood
22.08.2021 09:05

{данная программа переводит любое сочетание символов ascii в систему счисления заданную пользователем.}

//pascal abc.net v3.0 сборка 1111

var

  a,i,b,r,n,j,bug: integer;

  s,se,slo,slof: string;

procedure preob(var a,b,n: integer; var se: string);

  begin

  repeat

    b: =a mod n;

    a: =a div n;

    str(b,se);

    s+=se;

  until (a< =n-1);

  end;

beginreadln(slo);

readln(n);

for j: =1 to length(slo) do

begin;

a: =ord(slo[j]);

preob(a,b,n,se);

str(a,se);

s+=se;

for i: =1 to length(s) div 2 do

begin;

se: =s[i];

s[i]: =s[length(s)-i+1];

s[length(s)-i+1]: =se[1];

end;

write(s,'-');

slof: =slof+s;

delete(s,1,length(s));

end;

end.

пример ввода:

работа на завтра.

2

пример вывода:

11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-

{таким образом, фразу " работа на завтра." можно закодировать как "11000100-11101110-11101100-11100000-11111000-11101101-11111111-11111111-100000-11110000-11100000-11100001-11101110-11110010-11100000-100000-11101101-11100000-100000-11100111-11100000-11100010-11110010-11110000-11100000-101110-".}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота