В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Аха555
Аха555
20.11.2020 01:23 •  Информатика

Две целочисленный массив из 30 элементов . элементы массива могут принимать целые значения о 0 до 100 - учащихся выпускного класса за итоговый тестер информатике .составьте программу которая позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе ))

Показать ответ
Ответ:
zeinebde
zeinebde
05.10.2020 20:53
Program n1;
const n=30;
var a: array[1..n] of integer;
i,k,sum: integer;
sr: real;
begin
randomize;
sum:=0;
k:=0;
for i:=1 to n do
begin
a[i]:=random(101);
write(a[i],' ');
sum:=sum+a[i];
end;
sr:=sum/n;
writeln;
for i:=1 to n do if a[i]>sr then k:=k+1;
writeln(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота