В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
krivobokova45
krivobokova45
03.11.2021 01:49 •  Информатика

Добрый вечер! , , написать программу. в двухмерном массиве заменить на ноль элементы, чья сумма индексов равна заданному числу.

Показать ответ
Ответ:
миранда9
миранда9
19.08.2020 07:29
// PascalABC.Net 3.0, сборка 1066
// PascalABC.Net 3.0, сборка 1066
const
  nn=50;
  mm=50;
var
  a:array[1..mm,1..nn] of integer;
  i,j,m,n,k:integer;
begin
  Write('Введите число строк и столбцов массива: '); Read(m,n);
  Write('Введите значение, заменяемое нулем: '); Read(k);
  Randomize;
  Writeln('*** Исходный массив ***');
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4)
    end;
    Writeln
  end;
  Writeln('*** Результирующий массив ***');
  for i:=1 to m do begin
    for j:=1 to n do begin
      if i+j=k then a[i,j]:=0;
      Write(a[i,j]:4)
    end;
    Writeln
  end
end.

Тестовое решение:
Введите число строк и столбцов массива: 10 8
Введите значение, заменяемое нулем: 11
*** Исходный массив ***
 -23   8   2  -4   6  17 -11 -20
 -15 -18  -8  15   1   3 -12  -4
 -14   9   3  -2  20 -13  21 -23
 -20  24 -13  18  -6 -16 -19 -23
 -24 -25 -16   1   0  18  -7  -8
  -7  22  19  -6 -25  -6 -23  17
   9 -23  -7  18   5  -9  11  16
  12   0  -9   8   4  -4  12 -24
 -24 -10  13   1  -7  13  21  -6
  -9 -14 -21  24  -6   2 -24  11
*** Результирующий массив ***
 -23   8   2  -4   6  17 -11 -20
 -15 -18  -8  15   1   3 -12  -4
 -14   9   3  -2  20 -13  21   0
 -20  24 -13  18  -6 -16   0 -23
 -24 -25 -16   1   0   0  -7  -8
  -7  22  19  -6   0  -6 -23  17
   9 -23  -7   0   5  -9  11  16
  12   0   0   8   4  -4  12 -24
 -24   0  13   1  -7  13  21  -6
   0 -14 -21  24  -6   2 -24  11
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота