В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
щотььллл
щотььллл
20.09.2020 03:46 •  Информатика

Decimal to Binary На вход программе подается натуральное число, записанное в десятичной системе счисления. Напишите программу, которая переводит данное число в двоичную систему счисления. Формат входных данных На вход программе подается одно натуральное число. Формат выходных данных Программа должна вывести число записанное в двоичной системе счисления. Тестовые данные green_circle Sample Input 1: 5 Sample Output 1: 101 Sample Input 2: 128 Sample Output 2: 10000000 Питон

Показать ответ
Ответ:
Алексей22891
Алексей22891
18.10.2021 13:50

Программа:

n = int(input('Введите натуральное число (в 10-й СС): '))

k = ''

while n > 0:

   i = str(n % 2)

   n = int(n / 2)

   k = i + k

print(k)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота