В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AlimVolk
AlimVolk
02.08.2022 21:38 •  Информатика

ДАЮ 65Б НУЖНО РЕШЕНИЕ НА ЯЗЫКЕ ПИТОН ЧЕРЕЗ ЦИКЛ for
Задано натуральное число N. Напишите программу, которая выведет на экран все числа: сначала число N, а затем числа от 1 до N - 1.

Входные данные
Вводится одно натуральное число, не превосходящее 1000

Выходные данные
Выведите N - 1 натуральное число. Числа должны быть разделены пробелами.

Примеры
входные данные
5
выходные данные
5 1 2 3 4

Показать ответ
Ответ:
dinara169
dinara169
29.01.2021 09:40

#вводим число n

n = int(input())

#создаем массив

values = []

#проверяем что бы число не превышало 1000

if(n <= 1000):

#добавляем в массив число n

   values.append(n)

#делаем цикл и добавляем каждое число от 1 до n-1

   for i in range (1 , n):

       values.append(i)

#делаем цикл и выводим конкатинируя значения в 1 строчку

for i in range(0, len(values)):

   print(values[i], end = ' ')

0,0(0 оценок)
Ответ:
fhdhkfhydkfhs
fhdhkfhydkfhs
29.01.2021 09:40

n = int(input())

print_data = 0

while not n <= 1000:

   n = int(input())

output = []

output.append(n)

for i in range(1, 1000):

   output.append(i)

   if i >= n or i == 1000:

       output.pop(len(output) - 1)

       break

for i in range(0, len(output)):

   print_data = str(print_data) + str(output[i]) + ' '

print_data = print_data.replace(print_data[0], '', 1)

print(print_data)

print(output)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота