В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
toyru556
toyru556
19.10.2021 03:48 •  Информатика

Даны натуральные числа k и n. составить программу формирования массива а, элементами которого являются числа, сумма цифр которых равна k и которые не больше n.
составить программу на паскале.

Показать ответ
Ответ:
FireFox2017
FireFox2017
05.08.2020 08:29

uses crt;

type arr=array[1..1000]of integer;

 

var N, K, C: integer;

a : arr;

 

function sum(n:integer):integer;

var s:integer;

begin

s:=0;

while n<>0 do

begin

 s:=s+n mod 10;

 n:=n div 10;

end;

sum:=s;

end;

 

procedure fill(var a:arr, C, N, K: integer);

var i:integer;

begin

c:=0;

for i:=1 to N do if sum(i)=k then

begin

 inc(c);

 a[c]:=i;

end;

end;

 

begin

clrscr;

write('N K-> ');

readln(N, K);

fill(a, c, N, K);

for i:=1 to с do write(a[i],' ');

readln;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота