В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Инна200513
Инна200513
21.12.2020 13:44 •  Информатика

Даны коэффициенты квадратного уравнения a,b,c.напишите программу которая решает это квадратное уравнение.(в паскале)

Показать ответ
Ответ:
nikitagregorovi
nikitagregorovi
17.07.2020 16:55
Program Uravnenie;
uses Crt;
var a,b,c,x,x1,x2 : real ;
begin     
clrscr;
     writeln ( 'Введите a : ' );
     readln ( a );
     writeln ( 'Введите b : ' );
     readln ( b );
     writeln ( 'Введите c : ');
     readln ( c );
     if ( sqr ( b ) - 4 * a * c ) < 0
               then  writeln ( ' Уравнение не имеет решения ' )                                   else begin                         
if ( sqr ( b ) - 4 * a * c ) = 0 
                        then begin
                                   x:= - b / ( 2 * a );
                                   writeln( ' x = ', x : 8 : 2 )
                              end                         
else
 begin                                 
      x1:= ( - b + sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
      x2:= ( - b - sqrt ( sqr ( b ) - 4 * a * c ) ) / ( 2 * a );
      writeln( ' x1 = ', x1 : 8 : 2, ' x2 = ', x2 : 8 : 2 ) 
end
end.
0,0(0 оценок)
Ответ:
mehemmed20039
mehemmed20039
17.07.2020 16:55
Program s;
var a,b,c,x,z,d:real;
begin
write('Введите a,b,c');
read(a,b,c);
d:=(b*b)-(4*a*c);
if d<0 then write(' Уравнение не имеет корней')
else
x:=(-b+sqrt(d))/(2*a);
z:=(-b-sqrt(d))/(2*a);
write(' х равно ',x, ', ', z);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота