В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
arishaprohorenk
arishaprohorenk
13.07.2021 00:22 •  Информатика

Даны два натуральных числа. Напишите программу, которая определяет, в каком из них: а) больше цифр. б) сумма цифр больше НАПИШИТЕ ЕЩЁ ПРОГРАММУ, через 40 мин папа придёт и мне тогда будет кирдик, если я не сделаю​

Показать ответ
Ответ:
enatusya55
enatusya55
21.02.2021 17:57

Ниже

Объяснение:

def numberSum(n):

   d = 0

   k = 0

   while n:

     d = n% 10

     n/=10

     k = k + d

   return k

def charSum(n):

   counter = 0

   while n:

       n /= 10

       counter+=1

   return counter

a = int(input())

b = int(input())

if numberSum(a) > numberSum(b):

   print("Сумма чисел больше в a")

elif numberSum(a) == numberSum(b):

   print("Сума цифр равна")

else:

   print("Сумма чисел больше в b")

if charSum(a) > charSum(b):

   print("Символов больше в a")

elif charSum(a) == charSum(b):

   print("Количество символов равно")

else:

   print("Символов больше в b")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота