Даны два числа X и Y: X DD 28 Y DD 2 Написать программу вычисления N = X / Y. Записать результат в десятичной системе счисления. Написать программу на ассемблере вычисления выражения: e/d + a + b*c; где а =30; b =2; c = 5; е =48; d =6.
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017 // Внимание! Если программа не работает, обновите версию!
begin var n:=ReadInteger('Количество строк (столбцов) в массиве:'); Writeln('*** Исходный массив [',n,',',n,'] ***'); var a:=MatrRandom(n,n,-10,10); a.Println(4); Writeln(5*a.ColCount*'-'); var k,l:integer; Write('Введите L,K: '); Read(l,k); var lim:=a[l-1,k-1]; var s:=a.Rows.SelectMany(x->x).Where(x->x<lim).Sum; Writeln('Искомая сумма равна ',s) end.
//PascalABC.Net 3.0, сборка 1064 const n=20; var a:array[1..n] of integer; i,imax,imin:integer; s:longint; begin Randomize; Writeln('Исходный ряд значений'); imax:=1; imin:=1; for i:=1 to n do begin a[i]:=Random(51)-25; Write(a[i],' '); if a[i]>a[imax] then imax:=i else if a[i]<a[imin] then imin:=i end; Writeln; if imax>imin then Writeln('Максимальный элемент встретился позже минимального') else begin s:=0; for i:=imax+1 to imin-1 do s:=s+a[i]; Writeln('Сумма элементов между максимальным и минимальным значением ',s) end end.
Тестовое решение: Исходный ряд значений 10 -3 9 5 20 10 6 2 -19 -19 6 -24 -7 -1 23 11 -8 -16 -14 -25 Сумма элементов между максимальным и минимальным значением -27
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Количество строк (столбцов) в массиве:');
Writeln('*** Исходный массив [',n,',',n,'] ***');
var a:=MatrRandom(n,n,-10,10);
a.Println(4); Writeln(5*a.ColCount*'-');
var k,l:integer;
Write('Введите L,K: '); Read(l,k);
var lim:=a[l-1,k-1];
var s:=a.Rows.SelectMany(x->x).Where(x->x<lim).Sum;
Writeln('Искомая сумма равна ',s)
end.
Пример
Количество строк (столбцов) в массиве: 6
*** Исходный массив [6,6] ***
-4 -8 -7 -3 -6 -4
2 -9 1 9 -6 6
-9 -2 -8 -3 -1 -4
-1 -9 -3 -7 3 -3
5 9 -6 8 -1 -10
-1 -1 -5 -8 -9 4
Введите L,K: 2 3
Искомая сумма равна -138
const
n=20;
var
a:array[1..n] of integer;
i,imax,imin:integer;
s:longint;
begin
Randomize;
Writeln('Исходный ряд значений');
imax:=1; imin:=1;
for i:=1 to n do begin
a[i]:=Random(51)-25; Write(a[i],' ');
if a[i]>a[imax] then imax:=i
else
if a[i]<a[imin] then imin:=i
end;
Writeln;
if imax>imin then
Writeln('Максимальный элемент встретился позже минимального')
else begin
s:=0;
for i:=imax+1 to imin-1 do s:=s+a[i];
Writeln('Сумма элементов между максимальным и минимальным значением ',s)
end
end.
Тестовое решение:
Исходный ряд значений
10 -3 9 5 20 10 6 2 -19 -19 6 -24 -7 -1 23 11 -8 -16 -14 -25
Сумма элементов между максимальным и минимальным значением -27