В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kiradark15
kiradark15
09.10.2022 09:41 •  Информатика

Даны целые числа x и y. написать программу определения знака разности x-y. разность вычислять нельзя. разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.

Показать ответ
Ответ:
Ekaaaterina
Ekaaaterina
03.07.2020 01:26
Program raznost_xy;
var x, y:integer;
begin
write ('Введите число х = ');
readln (x);
write ('Введите число у = ');
readln (y);

if (x>0) and (y>0) then
  begin
    if abs(x)>abs(y) then write ('x-y > 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y < 0');
  end;
      
if (x<0) and (y<0) then
  begin
    if abs(x)>abs(y) then write ('x-y < 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y > 0');
  end;

if (x=0) and (y=0) then write ('x-y = 0');
if (x>0) and (y<0) then write ('x-y > 0');
if (x<0) and (y>0) then write ('x-y < 0');
if (x=0) and (y>0) then write ('x-y < 0');
if (x=0) and (y<0) then write ('x-y > 0');
if (x>0) and (y=0) then write ('x-y > 0');
if (x<0) and (y=0) then write ('x-y < 0');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота