В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
клубника25
клубника25
04.12.2021 19:22 •  Информатика

Дано положительное число не больше 99. Нужно составить программу, которая сообщает однозначное это или двузначное число.

Показать ответ
Ответ:
temaimcheg
temaimcheg
24.11.2021 01:35
Var St: string;
 z:string[10];
 x:string[2];
i,j,k,m: integer;           //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0;                       //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
 begin;
  for m:=1 to 10 do
   if St[j]=z[m] then inc(k);
 end;
if k=0 then
begin;
 writeln('в тексте нет цифр');
 exit;
end;                              //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
0,0(0 оценок)
Ответ:
Катя709015
Катя709015
13.02.2022 06:41
В двоичной системе: 1243(10)=2^10+2^7+2^6+2^4+2^3+2^1+1 = 1024+128+64+16+8+2+1 = 1243(10) =10011011011(2)
В восьмиричной системе:  разбиваете двоичное представление на группы по 3 бита справа налево
011  = 3
011  = 3
011  = 3
10   = 2
Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10)
В шестнадцатиричной системе:  разбиваете двоичное представление на группы по 4 бита справа налево
1011 = B = 11(10)
1101 = D(16) = 13(10)
100  = 4
Тогда в шестнадцатиричной системе
4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота