В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
146727
146727
07.04.2020 09:48 •  Информатика

Дано натуральное N. Написать программу вычисления N первых элементов последовательности Фибоначчи. на питоне

Показать ответ
Ответ:
ЬПОАСИ
ЬПОАСИ
31.10.2020 08:12

Довгий час знання, яких набувала людина протягом життя, передавались усно від покоління до покоління, що не забезпечувало безперервного поповнення бази знань людства в цілому. Безперервний процес збереження інформації забезпечила писемність, яка дозволяла накопичувати інформацію.

Спочатку люди викарбовували написи на камінні, потім видавлювали гострими паличками на глиняних дощечках. Писали паличками на папірусі, пензликами на шовку і перами на папері. Гусяче перо змінили ручки з металевим пером, а їх – графітові олівці, авторучки, а згодом друкарські машини.

Проте в роботі з текстами залишалося незмінним головне: щоб внести зміни в текст, його потрібно було щоразу переписувати або передруковувати. І лише застосування комп'ютерів і спеціальних програм принципово змінило технологію роботи з текстом. У чому ж полягають переваги у використанні ПК для обробки текстів?

Для роботи з текстом на ПК використовують: текстові редактори, текстові процесори та видавничі системи. У загальному їх називають системами обробки текстів – програми, які призначені для створення, редагування й друку текстових документів.

Текстовий редактор – це програма, що дозволяє вводити, редагувати, форматувати та зберігати текст.

Текстовий процесор – це програма, що дозволяє вводити, редагувати й форматувати текст, вставляти малюнки й таблиці, перевіряти правопис, складати зміст, виконувати перенос слів та багато інших складних операцій.

Настільна видавнича система (НВС) – це програма, за до якої можна створювати високоякісні оригінал-макети, що містять текст і графічні зображення для тиражування в друкарні.

Наприклад:

•    текстові редактори (Multi-Edit, Блокнот, WordPad, Твір, Лексикон);

•    текстові процесори (Microsoft Word, Word Prefect, OpenOffice, Word-Star);

•    настільні видавничі системи (Adobe PageMaker, Corel Ventura, Publisher, QuarkXPress).

Вивчаючи в 9-му класі роботу з текстовим процесором Word 2003, ви вже навчилися створювати текстові документи, редагувати і форматувати текст, вставляти в документ і форматувати векторні графічні зображення. Однак користувач майже завжди передбачає, що створений ним документ буде надрукований. Тому важливо оформити документ так, щоб він гарно виглядав не тільки на екрані, але й на аркуші паперу.

Объяснение:

0,0(0 оценок)
Ответ:
irina707
irina707
01.09.2020 02:08
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
function Avg(a:array[,] of integer):real;
begin
  var s:=0; var k:=0;
  foreach var e:integer in a do
    if e>0 then begin s+=e; Inc(k) end;
  if k>0 then Result:=s/k else Result:=1e-100;
end;

begin
  var A:=MatrixRandom(4,4,-50,50); Writeln(A);
  Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
  var B:=MatrixRandom(5,5,-30,30); Writeln(B);
  Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
  var C:=MatrixRandom(4,5,-25,38); Writeln(C);
  Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.

Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота