В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Дано натуральное число n. написать программу, выводящую последовательность чисел 1,2, (решить с while) по возможности решите еще и дано n натуральных чисел. написать программу, вычисляющую их среднее арифметическое (число n вводится перед всеми остальными числами ) дано натуральное число n. написать программу, выводящую степени двойки от первой до n-й 2,4,8,6

Показать ответ
Ответ:
supanzerbe
supanzerbe
02.10.2020 10:51
Var n,i:integer;
begin
write('N= ');
read(n);
i:=1;
while i<=n do
begin
writeln(i);
i:=i+1;
end;
end.

var n,i,sum:integer;
cp:real;
begin
write('N= ');
read(n);
i:=0;
while i<n do
begin
i:=i+1;
sum:=sum+i;
end;
cp:=sum/i;
writeln('Среднее значение натуральных чисел до N равно ',cp);
end.

var n,i,b,m:integer;
begin
write('N= ');
read(n);
b:=2;
i:=0;
write(b);
writeln;
while i<n-1 do
begin
i:=i+1;
b:=b*2;
writeln(b);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота