В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sasha11111222
Sasha11111222
22.09.2020 06:17 •  Информатика

Дано натуральное число m. написать программу для вычисления суммы вида: 45+42+39++m. входные данные n=38 выходные данные 126

Показать ответ
Ответ:
laura050027
laura050027
14.06.2020 11:46

Begin

Read(a);

Sum:=45;

I:=45;

While i>a do

Begin

I:=i-3;

Sum:=sum+i;

End;

Write(sum);

End.

Объяснение:

0,0(0 оценок)
Ответ:
sparksfiyfdgghffgg
sparksfiyfdgghffgg
14.06.2020 11:46

Ну, вот на Pascal написал. Вроде так...

var  

Sum, I : integer;

Sum := 0;

I := 45;

While I >= M do

begin

Sum := Sum + I;

I := I - 3;

end;

Writeln(Sum);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота