В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Дано два задания написать программу на паскале. Первую я написала, переделайте мою программу для второго задания. 1 ЗАДАНИЕ. Вывести фигуру квадрата 5х5 из чисел от 1 до 25 с “горизонтальной
разверткой”
2 ЗАДАНИЕ. Вывести фигуру квадрата 5х5 из чисел от 1 до 25 с “вертикальной
разверткой”

Программа для первого задания:
var
i:integer;
begin
for i:=1 to 25 do
begin
if i mod 5 <> 0 then
write (i, ' ')
else
begin
write (i, ' ');
writeln;
end;
end;
end.
Переделайте ее для второго задания.
Как вывелось в 1 задание (фото 1). Как должно выводится во втором задании (фото 2)


Дано два задания написать программу на паскале. Первую я написала, переделайте мою программу для вто
Дано два задания написать программу на паскале. Первую я написала, переделайте мою программу для вто

Показать ответ
Ответ:
kisilevars2003
kisilevars2003
10.01.2022 03:06

ну тут все Объяснение:

1. Берем процессор Intel Core i5 9400F. 6 ядер/6 потоков. Частота в турбобусте достигает 4,1 ГГц. Тепловыделение будет до 65 Вт, что не так уж и много. Средняя цена такого процессора 11 000 руб

2.Материнская плата Gigabyte Z390 UD с 12-ю фазами питания, радиатором зоны VRM и подсветкой. Плата поддерживает до 64 Гб памяти типа DDR4 на частоте до 4266 МГц. Цена - 7300 рублей.

3.Оперативная память Crucial Ballistix Sport LT DDR4. 2 плашки по 8 Гб ( 16 Гб в сумме) на частоте 3000 МГц CL15. цена 5800.

4.Видеокарта Nvidia RTX 2060 Super от Palit, версии JetStream. Если есть возможность добавить пару тысяч- возьмите модель старше, например 2070 Super.Цена 31 000 руб

5. Обязательно берём SSD, на 250 Гб под систему, например Samsung 860 EVO. Ну и HDD цена - примерно 5 тыс.

6.Блок питания Be quiet System Power9 на 600 Вт. Всевозможные защиты, отличный КПД и БП от хорошей фирмы за 4100 руб.

7. Корпус на свое усмотрение)

0,0(0 оценок)
Ответ:
Df77
Df77
22.05.2020 15:08
Const n=8;
var 
a:array[1..n,1..n] of integer;
i,j,k,s,s1,si,dmin,smin:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to n do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
write('k = '); readln(k);
s:=0;
for j:=1 to n do s:=s+a[k,j];
writeln('s = ',s);
dmin:=999999; smin:=999999;
for i:=1 to n do
 if i<>k then
  begin
  s1:=0; 
  for j:=1 to n do s1:=s1+a[i,j];
  writeln('s',i,' = ',s1);
  if abs(s1-s)<dmin then begin dmin:=abs(s1-s); smin:=s1; si:=i; end;
  end;
writeln('Номер строки = ',si,', smin = ',smin);
end.

Пример:
Исходный массив:
   9   0  22  40  20  35   2  25
  23  30  22  35  41   0   9  40
   1  15   6  18  43  47  34  33
  26   5   2  45  13  46  40   2
  26  39   7  31   3  43  20   8
  25  15  24   6  10  16   3  25
  47   0  27  35  14  15  36  11
  16  38  14  14  33   7  11  26
k = 5
s = 177
s1 = 153
s2 = 200
s3 = 197
s4 = 179
s6 = 124
s7 = 185
s8 = 159
Номер строки = 4, smin = 179
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота