В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
odinokijcelovek
odinokijcelovek
13.10.2020 22:00 •  Информатика

Дано два трехзначных числа. необходимо написать программу, которая определяет есть ли в этих числах цифра 3. если цифра 3 есть только в одном числе выводиться yes, если числ с цифрой 3 нет выводиться no. а если в двух числах есть цифра 3 выводиться большее из них. sample input: 341 552 sample output: yes ! язык питон где-то ошибка a = int( b = int( if a // 3 or b // 3 : print(" yes") else: print("no") if a//3 and b//3 and a > b: print(a) else: print(b) if a//3 and b//3 and a == b: print(a) else: print(b)

Показать ответ
Ответ:
MegaCrisp1
MegaCrisp1
01.01.2023 00:22
Вот программа : program xxx; 
<p>program xxx;</p><p>&nbsp;&nbsp; var i, k, d, e, s : integer;</p><p>begin</p><p>&nbsp; k:=0;</p><p>&nbsp;for i:= 10 to 99 do</p><p>&nbsp;&nbsp; begin</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; d:= i div 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; e:= i mod 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; s:=d + e;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; if i mod s = 0 then k:=k+1</p><p>&nbsp;&nbsp; end;</p><p>&nbsp;&nbsp; write ('кол-во чисел которые делятся на сумму своих цифр=', k);</p><p>&nbsp;&nbsp; readln</p><p>end.</p>
Найдите количество двузначных чисел, которые делятся на сумму своих цифр.
0,0(0 оценок)
Ответ:
Лёха142002
Лёха142002
28.01.2023 23:52
Program Ves;
Var a1,a2,a3,a4,t1,t2,t3,p,d,vp,b: Integer;
begin 
writeln ('программа вычисляет норму для данного ученика');
writeln ('введи массу учебника 1');readln (a1);
writeln ('введи массу учебника 2');readln (a2);
writeln ('введи массу учебника 3');readln (a3);
writeln ('введи массу тетради 1');readln (t1);
writeln ('введи массу тетради 2');readln (t2);
writeln ('введи массу тетради 3');readln (t3);
writeln ('введи массу пенала');readln (p);
writeln ('введи массу дневника');readln (d);
writeln ('введи массу портфеля');readln(vp);
b:=a1+a2+a3+a4+t1+t2+t3+p+d+vp;writeln ('общая масса портфеля= ' b);
if (b<=5) then writeln ('норма') else writeln ('ненорма');
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота