В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alionka7
alionka7
16.03.2022 18:03 •  Информатика

Дано два натуральных числа а и в. напишите программу, которая находит цифру, на которую заканчивается число а в степени b (ab).

Показать ответ
Ответ:
602158
602158
05.08.2020 09:21
C++

#include <cmath>

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL,"RUS");

  unsigned long a,b;

   cout<<"Введите число а"<<endl;

   cin>>a;

   cout<<"Введите число b"<<endl;

   cin>>b;

   cout<<((unsigned long)pow(a,b))%10;

   system("pause");

   return 0;

}

C#

using System;

class Power {

 static int Main() {

   ulong a, b;

   Console.WriteLine("Введите число а");

   a=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine("Введите число b");

   b=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine(Math.Pow(a,b)%10);

   Console.ReadKey();

   return 0;

 }

}

Pascal

program Power;

uses crt;

var

a,b,c:Int64;

i:byte;

begin

 writeln ('Введите число a');

 readln(a);

 writeln ('Введите число b');

 readln(b);

 

 c:=1;

 for i:=1 to b do

 c:=c*a;

 

 writeln (c mod 10);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота