В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nastushkaplushka
nastushkaplushka
24.08.2020 20:51 •  Информатика

Дано целое трехзначное положительное число n. составьте программу которая определяет входит ли в него цифра восемь.

Показать ответ
Ответ:
Гриша2148139
Гриша2148139
17.07.2020 00:02
Const ch=8;
var n:integer;
begin
read(n);
while n>0 do begin
if(n mod 10=ch)then begin
writeln('yes'); break;
end;
n:=n div 10;
end;end. 
еще можно в строку преобразовать и посимвольно проверить, но мне кажется так нагляднее и алгоритм проще
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота