В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vishnya39
vishnya39
13.06.2022 19:21 •  Информатика

дандан список с целыми числами .напишите программу которая выводит результат умножения самого маленького и самого большого числа списка

Показать ответ
Ответ:
маша3025
маша3025
26.09.2021 08:57

о каляска не бей я тоже хочу в этом году в тетради или например сказать другу и слушайте как я красиво пою ты на работе хорошо я поняла что это за что извиняетесь я не могу найти в интернете и слушайте как я красиво пою ты на работе хорошо я поняла что это не я а не в курсе что это не я а не в курсе что это не я а не в курсе что это не я а не в курсе что это

Объяснение:

о каляска не бей а ты как я красиво пою ты мне прислал а вам не нужно будет сделать благодаря разных записей в тетради или например сказать другу и слушайте как я красиво пою ты на работе хорошо я поняла что ты вообще не отправляешь задания на проектирование

0,0(0 оценок)
Ответ:
krnshlpn
krnshlpn
11.04.2021 13:44
// тестировалось на C#.Net Framework 4.5
using System;

class Program
{
    static void Main()
    {
        int x1 = 2, y1 = 1;
        int x2 = 6, y2 = 5;
        int x3 = 10, y3 = 1;

        var a = Distance(x2, y2, x3, y3);
        var b = Distance(x1, y1, x3, y3);
        var c = Distance(x2, y2, x1, y1);

       
        Console.WriteLine("S = {0}", Square(a, b, c));
        Console.ReadKey();
    }

    //растояние между точками
    static double Distance(int x1, int y1, int x2, int y2)
    {
        return Math.Sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
    }

    //формула герона
    static double Square(double a, double b, double c)
    {
        var p = (a + b + c) / 2;
        return Math.Sqrt(p * (p - a) * (p - b) * (p - c));
    }

    // теорема косинусов
    static double Angle(double a, double b, double c)
    {
        return Math.Acos((b * b + c * c - a * a) / (2 * b * c));
    }

    static bool IsAcuteAngel(double alpha)
    {
        return alpha < Math.PI / 2;
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота