В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sokolova2327
Sokolova2327
24.06.2020 05:36 •  Информатика

Дана программа: НАЧАЛО
ПОКА нашлось (01) ИЛИ нашлось (02) ИЛИ нашлось (03)
заменить (01, 103)
заменить (02, 10)
заменить (03, 210)
КОНЕЦ ПОКА
КОНЕЦ
Известно, что исходная строка начинается с цифры 0, а далее содержит
12 цифр 1, 15 цифр 2 и 17 цифр 3, расположенных в произвольном порядке.
Сколько цифр 2 будет в строке, которая получится после выполнения данной
программы?

Показать ответ
Ответ:
Соня2343
Соня2343
27.01.2023 04:20
Всё очень просто. Первый делом вы должны искать максимальный элемент массива, запоминая строку, в которой он находится. 
Далее нужно создать два массива : в первый записать значения строки, где находится максимальный элемент, а во второй - тот столбец К.
( Можете принять, что матрица квадратная, иначе следовали бы какие-то другие условия )
После этого уже понятно, как поменять элементы строки и столбца. 
Ещё можно создать дополнительную матрицу, но это будет не выгодно по памяти, да и по времени тоже.
Вроде бы понятно объяснил
0,0(0 оценок)
Ответ:
Marina56434655442
Marina56434655442
08.09.2022 09:53
Var
  t, h, mm, ss: integer;
  ct, ch, cmm, css: string;

begin
  Write('Введите время в секундах от начала суток -> ');Readln(t);
  h := t div 3600;
  t := t mod 3600;
  mm := t div 60;
  ss := t mod 60;
  Str(h, ch);
  ct := ch + ':';
  Str(mm, cmm);
  if Length(cmm) = 1 then ct := ct + '0' + cmm + ':' else ct := ct + cmm + ':';
  Str(ss, css);
  if Length(css) = 1 then ct := ct + '0' + css else ct := ct + css;
  Writeln('Указано время ', ct)
end.

Тестовое решение:
Введите время в секундах от начала суток -> 27429
Указано время 7:37:09
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота