В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Timm2517
Timm2517
12.01.2021 02:02 •  Информатика

Дана программа для редактора: НАЧАЛО
ПОКА нашлось (111)
заменить (111, 22)
заменить (222, 11)
КОНЕЦ ПОКА
КОНЕЦ

Известно, что исходная строка содержала более 100 единиц и не содержала других цифр. Укажите минимально возможную длину исходной строки, при которой в результате работы этой программы получится строка, содержащая максимально возможное количество единиц.

Показать ответ
Ответ:
555Sofia555
555Sofia555
25.07.2022 21:27

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int matrixSize = 5;

           int sum=0;

           int[,] matrix = new int[matrixSize, matrixSize];

           Random r = new Random();

           for (int i = 0; i < matrixSize; i++)

               for (int j = 0; j < matrixSize; j++)

               {

                   matrix[i, j] = r.Next(5) - 2;

                   if (matrix[i, j] % 2 != 0) sum += matrix[i, j];

               }

           for (int i = 0; i < matrixSize; i++)

           {

               for (int j = 0; j < matrixSize; j++)

                   Console.Write(matrix[i,j]+" ");

               Console.WriteLine();

           }

           Console.WriteLine("Сумма нечетных элементов матрицы равна " + sum);

       }

   }

}

0,0(0 оценок)
Ответ:
жак77777
жак77777
09.01.2022 21:05

Адекватная версия:

PascalABC.NET

begin

 var expr := Readstring();

 expr.Split(' ')[0].Println;

end.

Версия "Нас так учили"

var  

expression: string;

s_index: byte;

begin

 s_index := 1;

 readln(expression);

 while expression[s_index] <> ' ' do begin

   write(expression[s_index]);

   s_index := s_index + 1;

 end;  

 

end.

Объяснение:

Т.к по условию слово - последовательность непробельных символов, ограниченная пробелами или концами строки, то данная программа полностью игнорирует пунктуацию и считает любой символ частью того слова, с которым он не разделён пробелом.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота