Дана емкость дискеты (v=1.4 мегабайт). написать программу, которая бы по введенному номеру единицы измерения информации(1 – бит, 2 – байт, 3 – килобайт, 4 – мегабайт, 5 – гигабайт) переводила v в соответствующую единицу измерения
Во первых хочу заметить, что в реальном мире однозначно односторонних не бывает, особенно если дело касается живого
1) Источник: учебник Приемник: школьник.
2) Источник: письмо Приемник: бабушка.
3) Источник: будильник Приемник: мальчик.
7) Источник: газета Приемник: человек.
8) Источник: лист изменений Приемник: ученики. ??
10) Источник: знак Приемник: водители
11) Источник: билет Приемник: мальчик.
Все эти ситуации однотипные, односторонние по типу. Хотя конечно приемник может влиять на книгу/газету и тп, но информация в ней от этого не изменится
9) Источник: диспетчер. Приемник: пассажиры. ??
Вообще говоря случай односторонний, но возможно влияние на то что скажет диспечер. Например кто-то придет и скажет, что потерял ребенка и диспечер объявит об этом на всю станцию.
4) Источник: Таня, Лена Приемник: Таня, Лена. Двусторонний (и так все понятно)
5) Источник: учитель Приемник: класс
Впринцепе односторонний, но ученики могут задавать вопросы. Тут скорее двустороний подчиненный, без разрешения учителя, ученики ничего не говорят. С другой стороны учитель смотрит, как его слушают ученики, считывает настроение класса, тп
Это все-таки двусторонний процесс, регулировшик следит за машинами и ситуацией, решает как лучше разрулить ситуацию, а окружающие слушаются его команд.
Var a, b: integer; var c: string; begin writeln('Введите 1 число.'); readln(a); writeln('Введите 2 число.'); readln(b); writeln('Знак операции.'); readln(c); if c='*' then writeln(a*b); if c='/' then writeln(a/b); if c='-' then writeln(a-b); if c='+' then writeln(a+b); end. 2 ЗАДАЧА var a, b: real; begin writeln('Зарабаток Пети:'); readln(a); writeln('Зарабаток Петрова:'); readln(b); if a>b then writeln('Петя заработал больше Петрова.') else if a=b then writeln('Петров и Петя заработали одинаково.') else writeln('Петров заработал больше Пети.'); writeln('Среднее: ', (a+b)/2); end.
Во первых хочу заметить, что в реальном мире однозначно односторонних не бывает, особенно если дело касается живого
1) Источник: учебник Приемник: школьник.
2) Источник: письмо Приемник: бабушка.
3) Источник: будильник Приемник: мальчик.
7) Источник: газета Приемник: человек.
8) Источник: лист изменений Приемник: ученики. ??
10) Источник: знак Приемник: водители
11) Источник: билет Приемник: мальчик.
Все эти ситуации однотипные, односторонние по типу. Хотя конечно приемник может влиять на книгу/газету и тп, но информация в ней от этого не изменится
9) Источник: диспетчер. Приемник: пассажиры. ??
Вообще говоря случай односторонний, но возможно влияние на то что скажет диспечер. Например кто-то придет и скажет, что потерял ребенка и диспечер объявит об этом на всю станцию.
4) Источник: Таня, Лена Приемник: Таня, Лена. Двусторонний (и так все понятно)
5) Источник: учитель Приемник: класс
Впринцепе односторонний, но ученики могут задавать вопросы. Тут скорее двустороний подчиненный, без разрешения учителя, ученики ничего не говорят. С другой стороны учитель смотрит, как его слушают ученики, считывает настроение класса, тп
6) Источник: регулировщик Приемник: водители, пешеходы
Это все-таки двусторонний процесс, регулировшик следит за машинами и ситуацией, решает как лучше разрулить ситуацию, а окружающие слушаются его команд.
Объяснение:
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.