В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
тусикк
тусикк
19.03.2021 18:27 •  Информатика

Дана целочисленная линейная таблица а[115] составить программу с которой будет найдена сумма всех элементов таблицы кратных 5

Показать ответ
Ответ:
lolagrigoreva
lolagrigoreva
23.11.2021 19:05

26

Объяснение:

a = 23 (дано число a)

выполняем цикл (увеличиваем число a на 5 и проверяем условие число a больше 35, если условие истинно (да) выходим из цикла, если ложное (нет), то повторяем цикл)

a = a + 5 = 23 + 5 = 28

a > 35 (28 > 35, нет)

a = a + 5 = 28 + 5 = 33

a > 35 (33 > 35, нет)

a = a + 5 = 33 + 5 = 38

a > 35 (38 > 35, да)

a = a * 2 =  38 * 2 = 76 (увеличиваем число a в 2 раза)

проверяем условие является ли число a двузначным, если условие истинно (да), то выполняем левую ветку, а правую ветку (ещё один цикл) не трогаем (если условие ложно (нет), то выполняем правую ветку (ещё один цикл), а левую ветку не трогаем)

9 < a < 100 (9 < 76 < 100, да - двузначное)

a = a - 50 = 76 - 50 = 26 (уменьшаем число a на 50)

получаем ответ (больше ничего не делаем)

0,0(0 оценок)
Ответ:
Igor599
Igor599
13.12.2022 07:10

#include <iostream>

#include <vector>

using namespace std;

struct Year{

   vector<string> winter = {"December", "January", "February"},

                  spring = {"March", "April", "May"},

                  summer = {"June", "July", "August"},

                  autumn = {"September", "October", "November"};

};

void printWinter(Year &year_){

   for(auto &i: year_.winter)

       cout << i << " ";

   cout << "\n";

}

void printSpring(Year &year_){

   for(auto &i: year_.spring)

       cout << i << " ";

   cout << "\n";

}

void printSummer(Year &year_){

   for(auto &i: year_.summer)

       cout << i << " ";

   cout << "\n";

}

void printAutumn(Year &year_){

   for(auto &i: year_.autumn)

       cout << i << " ";

   cout << "\n";

}

signed main() {

   Year y;

   printWinter(y);

   printSpring(y);

   printSummer(y);

   printAutumn(y);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота