В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
мария2300
мария2300
05.09.2020 10:13 •  Информатика

Дан одномерный массив a [1..20] элементами которого являются целые числа. составьте программу подсчета суммы положительного элементов массива

Показать ответ
Ответ:
Патригг
Патригг
13.01.2022 16:32

а я разве их не решал

но ладнооо

1)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
Begin
clrscr;
readln(stroka);

i:=1;
repeat

val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;

until i=length(stroka);
x:=0;
for i:=1 to length(stroka) do x:=x+mas[i];
if x=10 then writeln('TRUE')
else writeln('ELSE');
end.

2 я не знаю как решать

3)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
begin
clrscr;
readln(stroka);
i:=1;
while i<=length(stroka) do begin
val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;
end;
x:=0;
for i:=1 to length(stroka) do x:=x+mas[i];
writeln(x);
end.

 4)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
begin
clrscr;
readln(stroka);
i:=1;
while i<=length(stroka) do begin
val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;
end;
x:=0;
for i:=1 to length(stroka)-1 do
for k:=1 to length(stroka)-i do if mas[k]=mas[k+1] then x:=x+1;
if x>0 then writeln('TRUE')
else writeln('FALSE');
end.

0,0(0 оценок)
Ответ:
annafilimonova1
annafilimonova1
01.01.2022 00:12
1. В каких случаях используется оператор цикла с параметром? Как он оформляется? Как он работает (что происходит при его выполнении)? Нарисуйте графическую схему выполнения. 

2. Что такое "тело оператора цикла"? 

3. Может ли тело оператора цикла с параметром не выполниться ни разу? 

4. Как должен быть оформлен оператор цикла с параметром, чтобы тело цикла выполнялось при уменьшающихся значениях параметра цикла? Как он будет работать (что будет происходить при его выполнении)? Нарисуйте графическую схему выполнения. 

5. Чему равно количество повторений тела оператора цикла с параметром, если параметр цикла принимает: 

а) все целые значения от 1 до 10? 
б) все целые значения от a до b? 
в) все нечетные значения от 1 до 20?1 
г) все нечетные значения от 1 до n?2 
д) все значения от 10 до 100 с шагом 7?3 
е) все значения от 1,5 до 10,3 с шагом 0,4?4 
ж) все значения от a до b с шагом step?5 

6. Можно ли в теле оператора цикла с параметром не использовать величину- параметр цикла? 

7. Почему в программировании существует правило: нельзя изменять параметр цикла в теле оператора цикла?
Правильно?
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота